Перейти к содержанию
Авторизация  
Н.В.Б.

бытовые электронные весы

Рекомендуемые сообщения

Если кто сталкивался с ремонтом, прошу помочь советом.

Весы Крупс F839. Схемы разумеется нет и не нашел. Тензодатчик прозвонил мультиметром, вроде нормально. Обычный мост.

Далее операционный усилитель, заменил аналогом, результат нулевой. Стоит смос еепром, для чего она не пойму.

Если есть у кого опыт, отзовитесь.

Поделиться сообщением


Ссылка на сообщение

В ЕЕПРОМе калибровочные данные весов, и сохраняются установки пользователя (например, в каких единицах измерения показывать).

 

встать вольтметром на выход ОУ, и пошевелить тензодатчик.

провести измерения, только с индикацией на вольтметре, без процессора.

если мост работает нормально, и виноват проц. то проверить наличие частоты на генераторе.

 

А вообще в чём неисправность заключается? Какие жалобы у клиента? :)

Поделиться сообщением


Ссылка на сообщение

А вообще в чём неисправность заключается? Какие жалобы у клиента? :)

Клиент, это я и есть. При включении на индикаторе высвечивается все восьмерки, затем Eror и весы выключаются.

Тензодатчик, как я понял собран по обычной мостовой схеме. Четыре резистора, на одну диагональ подается +5, с другой сигнал на вход операционника.

Там правда в одном корпусе четыре операционника, было начал разрисовывать схему по печатке, потом плюнул. Муторно. Проверил заменой на аналог, такая же фишка.

Навесные детали проверил все, вплоть до резисторов. И вот эта смос и АЦП, решил на базе пик контроллера.

На нем бумажка приклеена с какими то цифирками. Где может быть задающий генератор? Подумал, что встроен в контроллер, потому как вход синхро еепром соединен с ним. Индикация динамическая, значит генератор должен быть в норме.

Это я так думаю. Может ошибаюсь.

Поделиться сообщением


Ссылка на сообщение

А что, те бытовые весы какие-то уникальные что их обязательно ремонтировать надо? Ведь их полно всяких продается (правда китайских) и всего-то примерно по десять долларов за штуку. Как-то тоже возникли сомнения в правильности показаний таких весов, так я купил себе еще пару на всякий случай...

Поделиться сообщением


Ссылка на сообщение

А что, те бытовые весы какие-то уникальные

Вроде, нет. Китайскими , право не пользовался. Эти могут измерять как вес в граммах, так и обьем в миллилитрах.

Да и уставка есть, при достижении уставки заданного веса, запищат. Удобно, при монотонном взвешивании одного и того же веса.

Не надо тупо смотреть на шкалу при ври взвешивании дроби, когда снаряжаешь сотню патронов. А охота на носу:yahoo:

Поделиться сообщением


Ссылка на сообщение

Похожая хрень была на напольных Филипс (для теток, взвешиваться). Тоже загоралось Еррор. Причина была в том, что влезла тетенька за 100 кг и что-то там погнула, если приподымать крышку пальцем во время самотестирования, еррора не было, при отпускании - показывало около 300 граммов. Я так понял, что при каждом включении весы пытаются выставить 0, если крышка давит на тензодатчик сильнее определенного предела, или по другой аналогичной причине - будет еррор. Ищите механическую проблему. Те весы я починил, выбросив пружинки, фиксирующие крышку.

Поделиться сообщением


Ссылка на сообщение

На столе одна плата, без всяких крышек. То же самое.

Поделиться сообщением


Ссылка на сообщение

Ломается то, что шевелится....

Погнули тензодатчик? Типа, дробь для охоты на слонов взвешивали...

А без шуток, то наиболее вероятная причина - механическая.

Согласен с ww07.

Индикация проходит , т.е. проц жив.

Вольтметр на вход АЦП, нагружать разными весами и смотреть чего будет.

Поделиться сообщением


Ссылка на сообщение

Ломается то, что шевелится.... Погнули тензодатчик? Типа, дробь для охоты на слонов взвешивали...

Вроде на весы не садились и на пол не бросали:pardon:

Но ради эксперимента попробую нагрузить датчик в обратную сторону.

Поделиться сообщением


Ссылка на сообщение

Скорее всего проблема в памяти(EEPROM). Ошибка чтения данных вот и выдает EROR. Лечится програмированием если есть прошивка.

Поделиться сообщением


Ссылка на сообщение
Дата: (изменено)

Замерил мультиметром на выходе операционника. Непонятная фишка , 0,5вольта, через секунде 0,2 вольта и так по кругу. То так , то эдак.

Отпаял тензодатчик, замерил сопротивление моста. По 740 ом в каждом плече. Спаял четыре резистора по 750 ом в мост и подключил вместо датчика. На выходе операционного усилителя 3,15 вольта стоят мертво. Но на табло к EROR добавилась буковка L

Так, что, все таки тензо не исправен?

Изменено пользователем Н.В.Б.

Поделиться сообщением


Ссылка на сообщение

Похоже на то...

Поделиться сообщением


Ссылка на сообщение
Гость
Эта тема закрыта для публикации ответов.
Авторизация  

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу

×
×
  • Создать...

Важная информация

Мы разместили cookie-файлы на ваше устройство, чтобы помочь сделать этот сайт лучше. Вы можете изменить свои настройки cookie-файлов, или продолжить без изменения настроек.