Перейти к содержанию
KEI

Проблема с сервоприводом Omron

Рекомендуемые сообщения

Дата: (изменено)

Здравствуйте! Построил фрезер ЧПУ, поставил сервы X,Y - Panasonic, Z - Omron 200Вт с цифровым управлением. Проблема в том, что двигатель оси Z вращается только в одну сторону, ось всегда поднимается, даже если я пытаюсь её программно опустить. Ранее этот привод работал правильно, где-то месяц на станке не работал на время отпуска, а щас включил и вот такая картина. У меня нет совершенно никаких идей что могло произойти, потому что к станку я не прикасался вообще (свет в гараже отключали, не знаю могло ли это как-то повлиять..., буду благодарен любому совету, хотя бы в каком направлении думать, потому что у меня идей совсем нет...

P.s. пробовал переподключать ось Z на место оси X на контроллере, проблема сохранилась, то бишь дело не в контроллере

Изменено пользователем KEI

Поделиться сообщением


Ссылка на сообщение
53 минуты назад, KEI сказал:

Omron 200Вт с цифровым управлением

А точная марка Omron-а какая? И что Вы понимаете под цифровым управлением, степ/дир или управление по сети?

Поделиться сообщением


Ссылка на сообщение

По сети управляют контроллером ведь, а не сервоприводом, у сервопривода бывает цифровое и аналоговое управления или и то и другое, на  сколько мне известно. Точную марку контроллера чуть позже сообщу, щас с работы ухожу, заеду в гараж

Поделиться сообщением


Ссылка на сообщение

Может банально сбросились настройки на дефолт в отсутствии напруги? 

Поделиться сообщением


Ссылка на сообщение

Если управление по степдир, то скорее всего сигнал дир физически отвалился, где-то неконтакт. 

Поделиться сообщением


Ссылка на сообщение
37 минут назад, KEI сказал:

По сети управляют контроллером ведь, а не сервоприводом, у сервопривода бывает цифровое и аналоговое управления или и то и другое, на  сколько мне известно

У Вас сведения устарели. Так какая модель сервы?

19 минут назад, RegEdit сказал:

Может банально сбросились настройки на дефолт в отсутствии напруги?

Маловероятно, иначе при каждом включении пришлось бы программировать серву заново.

Поделиться сообщением


Ссылка на сообщение

По поводу того что dir физически отвалился есть сомнения, обычно в этом случае направление не одностороннее, а беспорядочное, то есть нажимаешь вверх, ось едет вниз, снова нажимаешь, она едет вверх, у меня такое было, но все равно проверю на всякий случай, со стороны контроллера ничего не отвалилось, если тока в самом разъёме, но я его не трогал...

 

привод вот такой

image1.jpeg

Поделиться сообщением


Ссылка на сообщение

Если провода в норме, то проверьте параметры Pn000 и Pn200

Поделиться сообщением


Ссылка на сообщение

Спасибо, проверю, А какие атрибуты правильные, собственно?)

Поделиться сообщением


Ссылка на сообщение

Это у Вас надо спросить, Вы же его программировали. Если оставили по умолчанию, то они приведены в мануале.

Поделиться сообщением


Ссылка на сообщение

Я не программировал, этим занимался продавец, причем даже он не делал этого вручную, настраивал через компьютер...

Поделиться сообщением


Ссылка на сообщение
Цитата

Это у Вас надо спросить, Вы же его программировали. Если оставили по умолчанию, то они приведены в мануале.

Вот мануал нашел, там куча пунктов под Pn200, а какой выбрать нужно подскажете или все подряд пробовать?...

 

Безымянный.jpg

Поделиться сообщением


Ссылка на сообщение

Для степ/дир первым надо поставить "0"

Поделиться сообщением


Ссылка на сообщение
7 минут назад, sergeijob сказал:

Для степ/дир первым надо поставить "0"

Ни степ ни дир в указанной таблице не вижу, ну pulse это step, понятно, но этот пункт не особо важен, двигатель то у меня крутится, а вот где тут dir? Объясните на пальцах, ибо я раньше тока с шаговиками имел дело, а с ними всё гораздо проще

Поделиться сообщением


Ссылка на сообщение
2 минуты назад, KEI сказал:

а вот где тут dir

reverse signal

Поделиться сообщением


Ссылка на сообщение
Дата: (изменено)
20 минут назад, sergeijob сказал:

reverse signal

"Feed pulse forward and reverse signal, positive logic", "Forward pulse and reverse pulse, negative logic" и оба они относятся к "Command pulse mode", а мне же нужно dir изменить, а не pulse или я что-то не так понимаю?

Вы пытаетесь мне сказать, что для параметра "Command pulse mode" нужно установить атрибут "0", правильно я понимаю?

Изменено пользователем KEI

Поделиться сообщением


Ссылка на сообщение
4 минуты назад, KEI сказал:

а мне же нужно dir изменить, а не pulse или я что-то не так понимаю? 

Изменить их по отдельности на данной серве Вы не можете.

6 минут назад, KEI сказал:

Вы пытаетесь мне сказать, что для параметра "Command pulse mode" нужно установить атрибут "0", правильно я понимаю?

Стоять должно "0" ( с большей долей вероятности) или "5"

Поделиться сообщением


Ссылка на сообщение
Дата: (изменено)

Понял, спасибо, после работы проверю что там с этим параметром. Правда вопрос о том, почему он сбился (если это так) остаётся открытым, ведь раньше работало всё... А если физически дир оборван, то направление движения было быть беспорядочным, а не односторонним, как я понимаю, короче странная ситуация, у меня с китайским приводом такая же беда, в итоге забросил, валяется и по-моему я игрался с этим параметром с позитивной/негативной логикой на китайце, бестолку... По-моему ещё где-то читал, что из-за неправильного заземления могут быть проблемы, хотя панасоники у меня вообще не заземлены и работают корректно...

Изменено пользователем KEI

Поделиться сообщением


Ссылка на сообщение
24 минуты назад, KEI сказал:

А если физически дир оборван, то направление движения было быть беспорядочным, а не односторонним,

Как раз, в большинстве случаев при правильном монтаже, будет односторонним.

26 минут назад, KEI сказал:

По-моему ещё где-то читал, что из-за неправильного заземления могут быть проблемы, хотя панасоники у меня вообще не заземлены и работают корректно...

Это как повезёт.

Поделиться сообщением


Ссылка на сообщение
05.08.2019 в 15:49, KEI сказал:

обычно в этом случае направление не одностороннее, а беспорядочное

что за сказки?!

если отвалился dir движение ВСЕГДА в одну сторону.

а вот если dir мерцает, то да, движение будет беспорядочным.

 

в серваке не сбивается ОДИН параметр. Если у него повалилась память, то повалилась вся!

05.08.2019 в 14:05, KEI сказал:

Ранее этот привод работал правильно, где-то месяц на станке не работал на время отпуска, а щас включил и вот такая картина.

Если вы не изменяли настройки САМИ, вариантов только два:

* отвалился сигнал физически

* завалилась ВСЯ память драйвера

 

скачайте CX-Drive (входит в комплект CX-One), выгрузите параметры и посмотрите что там и как.

Поделиться сообщением


Ссылка на сообщение
13 минут назад, n-a-v сказал:

Если у него повалилась память, то повалилась вся!

Был у меня случай, когда полетела всего одна ячейка, правда на ПЛК, а не на серве. Но элементная база у них одинаковая. Причём ПЛК современный и проработал всего пару месяцев.

17 минут назад, n-a-v сказал:

вариантов только два:

Добавлю третий-спалили вход.

Поделиться сообщением


Ссылка на сообщение
Дата: (изменено)
10 минут назад, sergeijob сказал:

Был у меня случай

у меня тут "случаев" хоть попой жуй.

10 минут назад, sergeijob сказал:

третий-спалили вход

это второй: "сигнал отвалился физически"

оно может быть и сдохший выход.

 

в любом случае "вскрытие покажет" :classic_biggrin:

 

более того, ТС не указал способ управления, это мы тут в гадалок играем, не более

Изменено пользователем n-a-v

Поделиться сообщением


Ссылка на сообщение
Дата: (изменено)
54 минуты назад, sergeijob сказал:

когда полетела всего одна ячейка, правда на ПЛК, а не на серве.

Что-то подобное тоже было . На  дешёвом китайском серваке один параметр упорно не менялся .  

Остальные были в нормальном режиме . А микросхема памяти - одна.

Изменено пользователем sermor

Поделиться сообщением


Ссылка на сообщение

а от сети привод запитан через понижающий трансформатор? он на 100В...

Поделиться сообщением


Ссылка на сообщение
Дата: (изменено)
1 час назад, Merkwurdigliebe сказал:

а от сети привод запитан через понижающий трансформатор? он на 100В...

Да, латр стоит

4 часа назад, n-a-v сказал:

более того, ТС не указал способ управления, это мы тут в гадалок играем, не более

Указал, цифровой (step/dir). Если вы о контроллере, то управляется контроллером mycnc ET6

4 часа назад, sergeijob сказал:

Добавлю третий-спалили вход.

Честно говоря не знаю как я мог вход спалить, несколько месяцев всё работало исправно, я ничего не менял, вся электроника запитана через стабилизатор напряжения

Изменено пользователем KEI

Поделиться сообщением


Ссылка на сообщение

Для публикации сообщений создайте учётную запись или авторизуйтесь

Вы должны быть пользователем, чтобы оставить комментарий

Создать учетную запись

Зарегистрируйте новую учётную запись в нашем сообществе. Это очень просто!

Регистрация нового пользователя

Войти

Уже есть аккаунт? Войти в систему.

Войти

  • Последние посетители   0 пользователей онлайн

    Ни одного зарегистрированного пользователя не просматривает данную страницу


×
×
  • Создать...

Важная информация

Мы разместили cookie-файлы на ваше устройство, чтобы помочь сделать этот сайт лучше. Вы можете изменить свои настройки cookie-файлов, или продолжить без изменения настроек.